Windows VM

Windows VM

Buddy supports Windows VMs that allow you to build .NET & ASP.NET in their native environment.

Creating custom AMI

If your build requires software not available in the default manifest, you can use your own AWS AMI template by following the instructions below.

Requirements

  1. Must have SSHD and Ubuntu WSL installed
  2. Windows SSH must be opened on port 22
  3. WSL Ubuntu SSH must be opened on port 2222
  4. For US regions: must be hosted on us-east-2 (Ohio)
  5. For EU regions: must be hosted on eu-north-1 (Stockholm)

Configuration

  1. Launch EC2 from ami-0bbf73c582f1925cd in us-east-2 (Ohio)
  2. Log in as Administrator with password WzQExQzeBur8t6rcpBlk;2fiXiV9HWYh
  3. Install all required software on the EC2
  4. Update Administrator password
  5. Create AMI from your EC2 instance

Windows VM software manifest

Microsoft Windows Server 2022 Datacenter 10.0.20348 N/A Build 20348

chocolatey 1.1.0
chocolatey-core.extension 1.3.5.1
chocolatey-dotnetfx.extension 1.0.1
chocolatey-fastanswers.extension 0.0.2
chocolatey-visualstudio.extension 1.10.0
chocolatey-windowsupdate.extension 1.0.4
dotnet-6.0-sdk 6.0.201
dotnet-6.0-sdk-2xx 6.0.201
DotNet4.5.2 4.5.2.20140902
DotNet4.6 4.6.00081.20150925
DotNet4.6-TargetPack 4.6.00081.20150925
DotNet4.6.1 4.6.01055.20170308
dotnetfx 4.8.0.20190930
KB2919355 1.0.20160915
KB2919442 1.0.20160915
KB2999226 1.0.20181019
KB3033929 1.0.5
KB3035131 1.0.3
KB3063858 1.0.0
netfx-4.5.1-devpack 4.5.50932
netfx-4.5.2-devpack 4.5.5165101.20180721
netfx-4.6-devpack 4.6.81
netfx-4.6.1-devpack 4.6.01055.00
netfx-4.6.2 4.6.2.20210905
netfx-4.6.2-devpack 4.6.01590.20210905
netfx-4.7-devpack 4.7.2053.20210905
netfx-4.7.1 4.7.1.0
netfx-4.7.1-devpack 4.7.2558.20210905
netfx-4.7.2 4.7.2.0
netfx-4.7.2-devpack 4.7.2.20210903
netfx-4.8 4.8.0.20190930
netfx-4.8-devpack 4.8.0.20190930
nuget.commandline 6.1.0
vcredist140 14.31.31103
visualstudio-installer 2.0.2
visualstudio2019-workload-universalbuildtools 1.0.1
visualstudio2019-workload-webbuildtools 1.0.1
visualstudio2019buildtools 16.11.11.0
wsl 1.0.1
linux ubuntu 18.04.2 LTS subsystem